當前位置:→ 股海網飛狐公式 → 正文
  • macd結構副圖(指標、副圖、飛狐、貼圖)

  • 相關簡介:macd結構副圖(指標、副圖、飛狐、貼圖) 有我的結構圖,就不用徐小明的定量結構了。 鈍化、結構形成、消失一目了然。另外加上了RIS指標。好不好用,你自己看。 新手上路,好用的多點紅心。 源碼 DIF:(EMA(C,N)-EMA(C,P1)),Precision2,COLORFF8000,LINEDOT; DEA:EMA(DIF,P2),Precision2,COLOR4080FF,LINEDOT; MACD:(DIF-DEA)*2,Precision2,LINETHICK0; {MACD底部結

  • 文章來源:股海網發布時間:2020-04-01 21:10:15瀏覽次數:下載次數:0收藏:

macd結構副圖(指標、副圖、飛狐、貼圖)

有我的結構圖,就不用徐小明的定量結構了。
鈍化、結構形成、消失一目了然。另外加上了RIS指標。好不好用,你自己看。
新手上路,好用的多點紅心。

源碼

DIF:(EMA(C,N)-EMA(C,P1)),Precision2,COLORFF8000,LINEDOT;
DEA:EMA(DIF,P2),Precision2,COLOR4080FF,LINEDOT;
MACD:(DIF-DEA)*2,Precision2,LINETHICK0;
{MACD底部結構預警}
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
{DRAWTEXT(死叉,DIF*1.05,'↓M死'),COLORF0DC97;}
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背離:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背離:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=(直接底背離 OR 隔峰底背離);
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背離,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背離,1)),LINETHICK0;
底背離消失:=(REF(直接底背離,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背離,1) AND DIFL1<=DIFL3);
STICKLINE(B OR BG,DIF,DEA,3,0),ColorYellow;{柱線帶}
DRAWTEXT((B AND COUNT(B,2)=1),(DIF*1.5),'鈍化'),coloryellow;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'形成'),colormagenta;
DRAWTEXT(FILTER(底背離消失,10),MACD*1.1,'消失'),colorgreen;
STICKLINE(BG,0,(DIF+DEA)*0.6,4,0), ColorRED;{柱線}
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
DRAWTEXT(金叉,DIF*1.05,'↑M金'),COLORRED;
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接頂背離:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰頂背離:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=(直接頂背離 OR 隔峰頂背離);
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接頂背離,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰頂背離,1));
頂背離消失:=(REF(直接頂背離,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰頂背離,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,(DIF+DEA)*0.6,3,0), COLORE79A32;{柱線}
STICKLINE(T OR TG,DIF,DEA,5,0),colorgreen;{柱線帶}
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'形成'),colormagenta;
DRAWTEXT(FILTER(頂背離消失,20),MACD*1.2,'消失'),colorgreen;
 FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
 FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
 FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
 FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
 FH5:=FH1 AND FH2 AND MACD<0.10;
二次翻紅:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
 DRAWTEXT(二次翻紅,MACD*1.5,'←復紅'),COLORFF80FF;
LC:= REF(C,1);
RSI1:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100,LINETHICK0,Precision1;
RSI2:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100,LINETHICK0,Precision1;
RSI3:=SMA(MAX(C-LC,0),24,1)/SMA(ABS(C-LC),24,1)*100,LINETHICK0,Precision1;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2),ColorWhite;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
RSI底背:=B3>0;
DRAWTEXT(B3>0,dif*1.05,'  R底背'),COLORred;{DRAWICON(B3>0,macd*1.2,1);{FILTER(B3>0,3),nodraw;
RSI頂背:=D3>0;DRAWTEXT(D3>0,dif*1.1,'R頂背'),ColorGreen;
STICKLINE(MACD>0 && REF(MACD,1)<MACD, MACD,0,0.11,0),COLORRED;
STICKLINE(MACD>0 && REF(MACD,1)>MACD, MACD,0,0.11,0),COLORYELLOW;
STICKLINE(MACD<0 && REF(MACD,1)<MACD, MACD,0,0.11,0),COLORMAGENTA;
STICKLINE(MACD<0 && REF(MACD,1)>MACD, MACD,0,0.11,0),COLORGREEN;

macd結構副圖(指標、副圖、飛狐、貼圖)

macd結構副圖(指標、副圖、飛狐、貼圖)

  • 下載資源所需積分

    0

  • 當前擁有積分

    0

股海網粉絲必讀
公式解密、改選股聯系QQ:78858997(有償服務)點擊查看詳情...
股海網指標公式幫助使用說明!新手必讀...
股海網新系統使用說明!新手必讀...
股海網VIP用戶組必讀...
說說看法 0
推薦資源

關于我們 - 聯系我們 - 廣告合作 - 下載聲明 - 網站幫助 - 友情鏈接 - SiteMap - TOP
Copyright © 2020 銘網科技,All Rights Reserved.湘ICP備09016573號-10
本站所有廣告和與股海網均無關系,請股友自行判斷真假!股海網客服QQ:78858997
股海網股票軟件下載中心
股海網股票書籍下載中心 湘公網安備43108102000040號
重庆幸运农场十分钟