當前位置:→ 股海網公式幫助 → 正文
  • 通達信選股公式常用代碼88條

  • 相關簡介:通達信選股公式常用代碼提供給股友方便編寫選股公式用

  • 文章來源:佚名發布時間:2020-06-11 21:01:19瀏覽次數:下載次數:0收藏:

通達信選股公式常用代碼提供給股友方便編寫選股公式用

縮量十字星選股公式:

5 10 20 60 120曰線.5線之上.縮量十字星.也就是前幾曰最高量的半倍量

五線上:=C>=MAX(MA(C,5),MAX(MA(C,10),MAX(MA(C,20),MAX(MA(C,60),MA(C,120)))));
縮量:=V<=HHV(V,10)*0.5;
十字星:=ABS(C-O)/C<=0.002 AND C/REF(C,1)<1.02;
五線上 AND 縮量 AND 十字星;

60天低吸公式

股價大于60天線,但與60天線距離小于5%

BETWEEN(C/MA(C,60),1.001,1.05);


1,30個交易日內,股價跌幅達到一半的股票

xg:(hhv(c,30)-c)/hhv(c,30)>0.5;

強股快踩選股公式

強股:=H/REF(L,1)>1.15 OR H/REF(L,2)>1.18;
快抽:=L/REF(H,1)<0.96 AND C
信號:REF(強股,1) AND 快抽;



3,兩天內,累計下跌等于或超過20%選股.
xg:(ref(c,2)-c)/c>0.2;

4,股價是25天以來新低.
xg:c

5,選股:EXPMA?。等张c10日金叉 并且第二天的收盤價在EXPMA的
5日線以上.
cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);

6,請編買入公式:
A. 將BIAS指標的參數設置為24日,將KD指標的參數設置為9;3;3。
B. BIAS指標要小于-6,這只是確認該股超跌的初選條件。
C. KD指標產生黃金交叉,K線上穿D線。
D. KD交叉同時,KD指標中的D值要小于16。
BIAS3 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,colorff00ff;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
xg:BIAS3<-6 and cross(k,d) and d<16;

7,要求是量大、換手率達到3左右,漲幅>7個點。
xg:v/capital*100>3 and (c/ref(c,1)>1.07;

10,股價回抽20日均線選股公式
xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c);

11,一根大陽線,至少有5個點以上,再連著出現二根振幅不大于5的十字星或是小K線
xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05 and count((h-l)/l<0.05,2)=2;

12,行情信息里的“漲幅”的原碼
(c-ref(c,1))/c*100;

13,kdj的J從上向下穿越O軸發出信號
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
xg:cross(0,j);

14,股價4天中有兩天在10日線上
count(c>ma(c,10),4)=2;


15,選出10天內出現過漲停的個股
count(c/ref(c,1)>1.1,10)>0;


16,一陽上穿10,20,30日線,量能是前一天3倍。
xg:cross(c,ma(c,10)) and cross(c,ma(c,20)) and cross(c,ma(c,30)) and
v>ref(v,1)*3;


17,共三根K線,第一根K線為陰線;第二根K線為陰線,最高價低于第一根K線
,最低價高于第一根K線;第三根K線陰陽不限,最高價低于第二根K線,最低價高
于第二根K線。滿足后發出信號~
w1:=ref(c,2)
w2:=ref(h,2)>ref(h,1) and ref(l,2)
w3:=ref(h,1)>h and ref(l,1)
xg:w1 and w2 and w3;


18, 選出今日成交量大于昨日成交量一成的股票。
xg:v>ref(v,1)*1.1;

19,股價上穿5周均線:
xg:cross(c,ma(c,5));
注意:選股時用周線

20,股價上穿30日均線的公式
xg:cross(c,ma(c,30));

21,量比大于1 同時換手大于2的公式
xg:v/ref(v,1)>1 and AMOUNT/CAPITAL*100>2;

22,當天開盤價與收盤價相等的選股公式
xg:c=o;

22,日均線向上 流通盤小于15000萬 換手率大于3的選股公式
lt:CAPITAL/100<15000;
換手:=VOL*100/CAPITAL<3;
w1:ma(c,5)>ref(ma(c,5),1);
xg:lt and 換手 and w1;

25,30內到本日收盤價下跌20%的公式
xg:hhv(c,30)/c>1.2;

27,30日均線走平或走高的個股
xg:ma(c,30)>ref(ma(c,30),1);

28,連續4天的收盤價格波動幅度在3%之內連續走平或向上
count(abs(c-ref(c,1)/ref(c,1))<0.03 and c>ref(c,1),3)=3;


29,上影線長于下影線
(c-l)>(h-c);

30,今天高開的公式
c>o;

33,換手率10天30%以上的選股公式
sum(VOL/CAPITAL*100,10)>30;

35,選出周換手率小于10%的股票
sum(VOL/CAPITAL*100,5)<10;

36,成交量創20日新低,并且股價也創20日新低
xg:v=llv(v,20) and c=llv(c,20);

37,"今日MACD等于昨天的MACD ,且macd>0" 的指標
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
xg:macd=ref(macd,1) and macd>0

39, 連續三天高開高走的選股公式
count(o>ref(c,1) and c>o,3)=3;


40,n天內曾經有m個漲停
count(c/ref(c,1)>1.09,n)>m;

41,連續3天每天的最低價都比前一天高
count(l>ref(c,1),3)=3;

42,周量縮小50%或40%或n%
a1:vol/capital*100;
xg:a1/ref(a1,1)

43,股價超過五日均價的15%以上,并給出賣出信號
賣出:c/ma(c,5)>1.15;


44,連收兩個十字星的選股公式
count(abs((c-o)/o<0.01),2)=2;

45,n橫盤天數,n1橫盤的上下幅度
REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(n1/100)
and ref(v,1)

46,振幅大于5%,收盤價大于3.5%小于15元,三日均線大于昨日的三日均線,去掉ST股。
a1:=h/l>1.05;
a2:=c>3.5 and c<15;
a3:=ma(c,3)>ref(ma(c,3),1);
xg:a1 and a2 and a3;

49,股價突破5ma買入,跌破5ma賣出。買入和賣出用箭頭表示 (副圖)
a1:cross(c,ma(c,5));
a2:cross(ma(c,5),c);
drawtext(a1,low*0.98,↑),colorred;
drawtext(a2,h*1.02,↑),color00ffff;

50,歷史高點到前一高點畫線
POLYLINE(h>=hhv(c,0),h);

52,20天均線向上的股
xg:ma(c,20)>ref(ma(c,20),1);


53, 連續3天收盤全是陰線。
count(c

54, 今天收盤價在昨天收盤價-2%~2%之間
c/ref(c,1)>0.98 and c/ref(c,1)<1.02;

55,收盤價在5日均線以上5天
count(c>ma(c,5),5)=5;

58,A。昨日量是n天以來最低量,(n可調);B。今日量是昨日量的m倍,(m可
調);C。今日k線收陽線;
xg:ref(v,1)=llv(ref(v,1),n) and v>ref(v,1)*m and c>o;

59,第一天收陰,第二天,第三天,第四天,收出紅三兵
XG:REF(C,3)O,3)=3;

60,月k線十字星收盤 并且5月線拐點向上。
XG:ABS(C-O)/O<0.02 AND MA(C,5)>REF(MA(C,5),1);
用月線選股


61,最近3天(包括昨天.前天)股價突破250日均線

COUNT(C>MA(C,250),3)=3;

63,條件:A: 假設大前天創最近新高,要求這天漲幅是超過7%的大陽線,且創最近
一個月的新高.B: 那么前天,昨天,今天都收小K線,要求小K線實體

xg:ref(c,3)/ref(c,4)>1.07 and ref(c,3)=hhv(c,20) and count(abs((c-ref
(c,1))/ref(c,1)<0.02,3)))=3;

65, 今天漲停的公式

C/REF(C,1)>1.09;


66,10日內有漲停的公式今漲停:=C/REF(C,1)>1.09;
選股:count(今漲停,10);


67,昨日前日漲停的REF(C,1)/REF(C,2)>1.095;

68,近5日K線最高價和最低價格波動在10%以內,成交量是昨日2倍,收盤漲5%
XG:(HHV(C,5)-LLV(C,5))/LLV(C,5)<0.1 AND V>REF(V,1)*2 AND C/REF(C,1)
>1.05;


69, 能在圖上提示個股(不含S或ST股)出現過的漲跌停板日期的公式
w1:if((c-ref(c,1))/ref(c,1)>0.1,date-1000000,c);


71,5日,10日,20日、30日貼近公式,越貼越好
m1:=ma(close,5);
m2:=ma(close,10);
m3:=ma(close,20);
m4:=ma(close,30);
y1:=max(max(max(m1,m2),m3),m4);
x1:=min(min(min(m1,m2),m3),m4);
黏合:y1/x1

在公式編輯器中有個參數表,依序填入 N   1     10     1.01,選股時N可以任意填你想填的數(N.1.01---1.03)

72,均線粘合公式(5.10.20.30)

n:=1.01;
m1:=ma(close,5);
m2:=ma(close,10);
m3:=ma(close,20);
m4:=ma(close,30);
y1:=max(max(max(m1,m2),m3),m4);
x1:=min(min(min(m1,m2),m3),m4);
黏合:y1/x1


72, 30天線拐頭向上出現提示
ma(c,30)>ref(ma(c,30),1);

73, 今天的換手率大于前天的一倍以上
w1:=v*100/capital;
w1>ref(w1,2)*2;

74, K線沿著5日均線往上爬的選股公式

w1:ma(c,5);
w2:abc(c-w1)/w1<0.01;
xg:count(w1>ref(w1,1),5)=5 and w2;


75, 20日均線,上穿62日均線 xg:cross(ma(c,20),ma(c,62));


76, 平臺整理的公式,整理時間和整理幅度可調(???)

COUNT(CLOSE,0)>N AND
(HHV(CLOSE,N)-LLV(CLOSE,N))/LLV(CLOSE,N)<=(N1/100);
N整理時間,N1整理幅度

79, 第一天股票漲停,第二天成交量是第一天成交量的1倍,并超過10%.那第三天
就是買點
w1:=ref(c,2)/ref(c,3)>1.1;
w2:=ref(v,1)/ref(v,2)>2;
xg:w1 and w2;

80, 3日均線上穿10日均線,KDJ有效金叉
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
w1:=cross(ma(c,3),ma(c,10));
xg:w1 and cross(k,d);

81, 30日均線拐頭向上ma(c,30)>ref(ma(c,30),1);

82, 連續3-5天,每天的收盤價漲跌幅不超過1%.w1:abs(c-o)<0.01;
xg:count(w1,5)>=3;

83, K線收十字星abs(c-o)/o<0.01;

85, MACD在8天以內兩次金叉DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
w1:cross(DIFF,dea);
xg:count(w1,8)>=2;

86, 股價于20日均線相差2個百分點的
w1:abs(c-ma(c,20)/ma(c,20)*100<2;
N日均線相差M個百分點的公式.
w1:abs(c-ma(c,n)/ma(c,n)*100
n:N日 m:M個百分點

87, MACD的拐點公式DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
拐點:ref(macd,2)>ref(macd,1) and ref(macd,1)

88,成交量是前5天中其他任何一天的10天均量線的3.5倍以上
w1:=llv(ma(v,10),5);
xg:v>w1*3.5;

串陽回踩公式

串陽:=COUNT(C>=O,N1)=N1;
串陰:=COUNT(C
信號:REF(串陽,N2) AND 串陰;  

通達信選股公式常用代碼88條

  • 下載資源所需積分

    0

  • 當前擁有積分

    0

上一篇:(給下面公式上穿)做個選股  下一篇:沒有了
股海網粉絲必讀
公式解密、改選股聯系QQ:78858997(有償服務)點擊查看詳情...
股海網指標公式幫助使用說明!新手必讀...
股海網新系統使用說明!新手必讀...
股海網VIP用戶組必讀...
說說看法 0
推薦資源

關于我們 - 聯系我們 - 廣告合作 - 下載聲明 - 網站幫助 - 友情鏈接 - SiteMap - TOP
Copyright © 2020 銘網科技,All Rights Reserved.湘ICP備09016573號-10
本站所有廣告和與股海網均無關系,請股友自行判斷真假!股海網客服QQ:78858997
股海網股票軟件下載中心
股海網股票書籍下載中心 湘公網安備43108102000040號
重庆幸运农场十分钟